Twitter APIToday Twitter retired its API v1, an act that killed many apps that were not using their latest API version. AJAX Scroller was also affected and it stopped displaying Tweets since this morning. We worked hard to fix it as quickly as possible so you can continue using Twitter with AJAX Scroller. So, the same day we are pleased to announce availibility of the new version of AJAX Scroller which implements Twitter API 1.1. Read on for configuration instructions. Twitter now requires authentication for all kind of calls to its API, even for publicly available data. As a result, you will have to register an application on dev.twitter.com and enter the keys you get to AJAX Scroller parameters on your site. Once you configure it, AJAX Scroller will work with Twitter just as before, even little better because of increased number of requests you can now make to Twitter API.

Following step-by-step instructions describes exactly how to do it.
  1. Download the latest AJAX Scroller version 2.5.1 and install / update it on your Joomla site.
  2. Go to https://dev.twitter.com and sign-in using your Twitter credentials.
  3. In the upper right corner, click on your profile, then on "My applications".
  4. Click on "Create a new application" button.
  5. On the new page fill in the Application Details. The application will be your website, so the details can be as shown on the screenshot below.
    You can leave the Callback URL empty, agree to the terms, fill in the captcha and click on the "Create your Twitter application" button.
  6. Your app will be created and already on the next page, under "OAuth settings", you will see the first 2 keys you need: "Consumer key" and "Consumer secret". Copy them over to AJAX Scroller parameters.
  7. Now click on "Create my access token" button on the bottom of the page.
  8. The access token will be created and you will get final 2 keys you need to copy over to AJAX Scroller parameters: "Access token" and "Access token secret".
  9. After you've copied the 4 keys to your AJAX Scroller parameters, save the module and you will be able to use it with Twitter just like before.
    You can verify that it's working on AJAX Scroller DEMO site.

As always, the upgrade is free for existing AJAX Scroller users within the subscription period. Click here to download the upgrade.

Rest of you, get AJAX Scroller 2.5.1 now: purchase AJAX Scroller.

JoomlaHigh quality Joomla! components by one of the original core developers of Joomla!

Latest Comments

Re: Compatibile with Joomla 3.5 and PHP 7 I understand your confusion, but you need to know...
Re: Compatibile with Joomla 3.5 and PHP 7 I would take that at face value, except it...
Re: Compatibile with Joomla 3.5 and PHP 7It lists compatibility with Joomla 3, that includes 3.5.
Re: Compatibile with Joomla 3.5 and PHP 7 I this true even though the Ajax register page...
Re: Introducing Text Scroller for Joomla Hello ChokDK.I install the modulo text scroll. But dosent...

About us

We provide high quality Joomla components created by a co-founder and original core developer of Joomla. For over a decade, our products have been used by more than 20.000 webmasters around the world.

We also recommend

Twitter

sakicnet: Load time of https://t.co/yhz7Uu9Sth w. Pingdom Tools: 2.19 s from New York, USA. Size: 762.3 kB. Rqsts: 32. https://t.co/BlMudbZXn0 52 days ago from Twitter Web Client

Stay in touch